依赖与版本

npm install yarn -g

包依赖对包的成功至关重要。 你很可能会用到其他包里已有的代码来开发自己包的功能。 那些“其他包”称为项目依赖。

所以依赖都在 package.json 文件里声明,包含开发依赖、运行依赖、可选依赖等。 每个依赖都需要指明依赖名称和最低可用版本。

yarn.lock 里保存了每个依赖的安装版本,这可以确保你的包每次安装的一致性。