安装依赖项

npm install yarn -g

如果刚从版本控制系统里 checkout 一个包,则需要为其安装依赖。

如果是为现有的包增加依赖,那么这些新的依赖会自动安装。

安装依赖项

yarn install 是用于安装一个项目的所有依赖。 Yarn会从package.json中读取依赖,并将依赖信息存储到yarn.lock中。

如果你正在开发一个包,通常你会在以下情况之后进行依赖安装:

  1. 你刚检出需要这些依赖项的项目代码。
  2. 项目的另一个开发者添加了新的依赖,你需要用到。

安装选项

有很多参数可以控制依赖安装的过程,包括:

  1. 安装所有依赖:yarnyarn install
  2. 安装一个包的单一版本:yarn install --flat
  3. 强制重新下载所有包:yarn install --force
  4. 只安装生产环境依赖:yarn install --production

查看您可以传递给 yarn install完整参数列表